ID:132521
 
Why has findText been replaced by findtextEx?
I heard that it relied on the capitalization of the command and could get confusing yet the new command findtextEx has a capital too...
Isenggard wrote:
Why has findText been replaced by findtextEx?
I heard that it relied on the capitalization of the command and could get confusing yet the new command findtextEx has a capital too...

findtext() vs. findText() was a little on the ambiguous side, and is a naming convention that isn't really used by any other language. Also it caused us headaches when people used certain crappy browsers to browse the old reference, because one particular unworthy browser treated anchors with different capitalization as identical.

Lummox JR
In response to Lummox JR
Lummox JR wrote:
Isenggard wrote:
Why has findText been replaced by findtextEx?
I heard that it relied on the capitalization of the command and could get confusing yet the new command findtextEx has a capital too...

findtext() vs. findText() was a little on the ambiguous side, and is a naming convention that isn't really used by any other language. Also it caused us headaches when people used certain crappy browsers to browse the old reference, because one particular unworthy browser treated anchors with different capitalization as identical.

Also [link]

We have plans to overhaul the language to remove a lot of the confusing syntax, though. findText/findtextEx would be reanamed to something like text.FindExact, for instance.
In response to Tom
Tom wrote:
findText/findtextEx would be reanamed to something like text.FindExact, for instance.

String.Things? Why use text?
In response to Falacy
That was just an example, it would probably be named a bit smarter.

var/String/text = "Hello world!"
var/found = text.FindExact("Hello")


Or something similar.
In response to Nadrew
Nadrew wrote:
That was just an example, it would probably be named a bit smarter.

> var/String/text = "Hello world!"
> var/found = text.FindExact("Hello")
>

Or something similar.

I always liked "text" because that's what it is: text. What is a "string" anyway? Even a "string of characters" doesn't make much sense. This notation is only used in coding but since so many of us programmers are used to it, it seems second-nature.
In response to Tom
As far as BYOND is concerned, I agree with keeping it "text". I'd rather see the language be intuitive than just follow the footsteps of other languages.
In response to Airjoe
Keeping it /text is fine. We can always do

String
parent_type = /text