... Anybody with a brain should be able to figure out that "src.brain_power++" is talking about a variable without the var_ being there.
I accounted for the people who don't directly associate what they are working with. For example :
mob/proc/gainOneHealth()
myHealth += 1
instead of what I prefer :
mob/proc/gainOneHealth()
src.myHealth += 1
Although you and DT are truly correct that it's not required. It's more of an emphasis to name data more precisely.
I honestly don't use the "type_" but a very few amount of people have benefited from it's usage.
It's always nice to see posts like this, though! I can tell you put some effort into it.
Too much writing makes the code look bad to other people. Too little writing (too many abbreviations; difficult to read) makes the code look bad to other people. There's a happy medium, I think.